(26 janvier 2006)

Bonjour à tout le monde !

Et merci pour les nouveautés que vous mettez à disposition !
J'ai deux questions à propos de la fusion WikiniMST et S5 qui nous donne la Fonction Prez
  • Que doit-on exactement transférer (écraser ou ajouter) pour obtenir cette fonction lorsque notre version MST est déjà la 0.4.3 ?
    • faut-il simplement rajouter quelque chose ou écraser complètement la version précédente par celle-ci
  • Que manque-t-il exactement pour avoir la page sous forme de diaporama qui s'affiche quand on a installé la dernière version MST du 10.01.06 sur un nouveau site ?
    • j'ai fait un test simplement en copiant le code source que vous proposez ici, mais les pages ne s'affichent pas avec le fond d'écran du type diaporama
    • je pense qu'il me manque quelques éléments (CSS ? et autre ?)

Merci de bien vouloir me répondre ...
  • > j'aimerais pouvoir montrer cette nouvelle fonction dans une formation pour des formateurs mitic qui aura lieu le 6 février prochain !

Avec mes salutations les meilleures et mes bons voeux en ce début d'année
CoRinne


Bonjour. Merci de vos commentaires.

Un écrasement de tous les fichiers serait ok. Mais voici les fichiers à ajouter/modifier pour une installation avec moins de risques.

Faire une sauvegarde du répertoire complet de votre installation de wikinimst, au cas ou...
Dans les nouvelles sources du WikiniMST vous trouverez les fichiers demandés.
  • Écraser le fichier /formatters/wakka.php pour prendre en considération: #F#, #D#, ~ -->> OK
  • Ajout des fichiers prez.php, prez2.php, prez3.php (+ prez4.php et prez5.php) dans /handlers/page/ (contrôle la sortie). -->> OK
  • Ajouter fichier /action/prez.php pour afficher un lien vers les 3 styles différents. -->> OK
  • Écraser le fichier /actions/attach.class.php afin que l'image update.png ne soit pas visible dans la présentation. -->> OK

Avec ces modifs, vous aurez la possibilité d'utilser la fonction prez.

Au plaisir. Pierre Lachance.



Me revoici à charge !

J'ai bien installé et écrasé tous les fichiers selon vos indications (très précises, merci).
Mais je me rends compte que j'ai le même problème que celui décrit dans ma deuxième question décrite plus haut :

Je suis désolée de vous importuner avec mes petits tracas... et espère ne pas vous prendre trop de temps !
merci beaucoup pour votre présence, vos idées et votre disponibilité

270106-> PL: Oups! J'ai oublié de vous dire que vous devez copier le répertoire /ui (c'est le coeur de S5) à la racine de votre wikinimst :o(

290106-> SUPER, MERCI BEAUCOUP !!!
merci



Re-bonjour

(2 mars 2005)

Il y a quelques temps déjà (voir ci-dessous), je vous ai fait part de mon problème à la suite de l'installation du WikiniMst : l'éditeur visuel ne fonctionne pas. Jusqu'à présent, j'ai simplement travaillé manuellement.
  • vous me proposiez de contrôler si tous les fichiers étaient bien installés :
    • ACeditor.buttonsBar.php >> OK
    • ACeditors.js >> OK
    • ACeditors.php >> pas trouvé
  • j'ai suivi votre conseil en allant revoir dans les fichiers décompressés "SourcesDuWikiniMst" (version du 21/12/04).
    • je n'y ai malheureusement pas du tout trouvé le fichier ACeditors.php
  • auriez-vous donc l'amabilité de me le faire parvenir d'une autre manière ? si c'est bien cela qui me manque.
Je vous remercie par avance pour votre collaboration et votre disponibilité.

PL: Désolé, le fichier ACeditors.php n'exite pas, c'est ACeditors.js que je devais écrire :o( Est-ce que vous avez un de vos wikini (sur le même serveur que celui qui ne fonctionne pas) où l'éditeur fonctionne? Est-ce ce wikini dont vous me parlé: http://php.educanet2.ch/corinne/ ? N'obtenant pas de message d'erreurs, la première solution que je vous suggère est d'écraser (faire une sauvegarde du dossier avant ) le wikini avec celui des dernières sources. C'est peut être un des fichiers qui est corrompu.

J'ai fouillé un peu et j'ai trouvé que le fichier ACeditors.js a été modifié. Donc écraser ce fichier en premier avec celui des sources.

Corinne : Merci pour vos indications, ça marche !!!
j'ai essayé de contrôler de manière systématique pour voir ce qui ne fonctionnait pas :
1. j'ai commencé par écraser les fichiers AcEditor?.buttonsBar.php et AcEditors?.js, mais rien ne changeait
2. j'ai ensuite écrasé l'ensemble des fichiers de la Source WikiniMst
3. l'éditeur visuel fonctionnait effectivement correctement
4. pour retrouver les changements dans les feuilles de style, j'ai réinstallé un par un les fichiers suivants : wakka.css / wakka.basic.css / wakka.php / wakka.config.php, en contrôlant après chaque transfert si l'éditeur fonctionnait encore.
5. le fichier corrompu était wakka.php.

JE VOUS REMERCIE BEAUCOUP POUR VOTRE PATIENCE A MON EGARD !

PL: Vous avez une très bonne compétence de résolution de problème. Je suis content pour vous que ça fontionne. Bon WikiNiMST!




Bonjour,

Je viens d'installer le squelette Wikinimst sur Wikinitest,
MAGNIFIQUE !!!!!

Les fonctionnalités les plus intéressantes à mon goût :

  • le menu de gauche
  • la fonction imprimer
  • l'éditeur de texte et les nouvelles possibilités de formatage
  • la fonction fichier attaché pour insérer des images

  • et il y a toutes celles que je n'ai pas encore eu le temps d'observer pour me réjouir !

    Ces fonctionnalités sont vraiment quelque chose d'intéressant au niveau de la convivialité et
    amènent encore plus de facilité d'accès pour des gens vraiment complétement novices !

    J'en viens donc à l'objet de ma réflexion....
    Nous possédons également, une collègue et moi-même un bureau de travail collaboratif de Corinne et Véro
    adresse dont je crois vous avoir déjà parlé ici.

    J'aimerais savoir si il est complexe de changer de version de WiKini? 0.4.3 à WikiniMst,
    c'est-à-dire une mise à jour en quelque sorte, étant donné que certaines modifications
    ont été apportées à la version utilisée actuellement (calendrier installé, changement dans la css, ...)


    J'essaierais (avant, faire des sauvegardes des la BDD et du répertoire du wikini) d'écraser les fichiers du wikini 0.4.3 avec ceux du WikiniMST. Après, suivre les instructions ici: InstallerConfigurerWikiniMST Bonne chance.


    Ca marche, MERCI BEAUCOUP pour votre travail et votre patience !
    (description de la démarches et des petits couacs ici : http://php.educanet2.ch/corinne/wakka.php?wiki=EcraserWikiniPourWikiniMst)



    Ho! Merci à vous de la documentation, je l'ajoute sur la page officiel de WikiniMST. Au plaisir.



    Dernier petit souci tout de même, le formulaire d'envoi de fichiers ne fonctionne pas. Et je ne sais pas trop où l'on peut déceler cette erreur !

    Hum... qu'est-ce qui ne fonctionne pas? Si vous écrivez le code {{attacher fichier="nom.txt" description="ce que veut dire le nom"}} avez-vous un ? au côté de nom.txt? En cliquant dessus avez-vous le formulaire qui fait parcourir sur votre disque? >> J'ai trouvé l'erreur : elle se situait au niveau de la réécriture automatique.

    >> Pour cette mise-à-jour, j'ai donc procédé par étape, pour éviter tous problèmes de perte de données (oui, je suis quasi parano à ce niveau-là et surtout peu expérimentée en mysql et php)
    1. Installation d'un wikiniMst en effaçant une ancienne version (sur un site test)
    2. Installation d'un wikiniMst sur un ancienne version en écrasant les fichiers ftp et en réutilisant la base de données d'origine (sur un deuxième site test) - d'où ma description de démarche
    3. Installation idem sur Notre site de travail, en corrigeant les fichiers wakka.config / wakka.css / wakka.php
    Remarques :

    • les scripts de type java ne fonctionne pas (mais j'avoue n'avoir pas chercher à fond dans vos explications qui me paraissent qqfois un peu complexes) PL script java ou javascript? Car il n'y a pas de java dans wikini.
    >> Nous utilisions un script java de statistique (netstat basic) fonctionnel avec la version wikini standard, mais il n'est pas reconnu dans la version Mst que j'ai installée. On le remarque parce que la page ne s'affiche plus du tout correctement : le pied de page n'est plus accessible d'où un problème d'édition. PL: Ha, ok, ajouter de nouvelles fonctions au wikinimst est un peu différent que sur le wikini officiel car des fichiers ont été modifié. Désolé :o(
    (27 janvier 2005)
    • ~>> On ne peut donc trouver nulle part une parade à ce problème ? En fait, ce script de statistique que nous utilisons depuis 1 année nous permet de montrer, à notre chef entre autre, et d'observer les fréquentations du site et nous serions très contente de pouvoir le réinstaller !

    (27 janvier 2005)
    >> l'éditeur visuel ne fonctionne pas, je dois donc taper "manuellement" les différentes fonctions voulues comme pour la grandeur ou la couleur de police
    • ~PL: quel type de serveur utilisez-vous? Quel navigateur (est-ce qu'il fonctionne pour vous dans le présent wikini?) utilisez-vous ?
      >> Nous utilisons Firefox, Mozilla, et Internet Explorer, et sur aucun de ces navigateurs la barre d'édition n'est fonctionnelle. Ce qui me fait penser qu'il doit s'agir d'un problème interne à l'installation et aux fichiers
      >> Et il s'agit d'un problème qui ne se montre que sur un seul des wikini installés (http://php.educanet2.ch/corinne) et j'arrive tout à fait bien travailler avec la barre d'édition de ce wikini-ci.
    • ~>> D'où cette remarque :

    Ca marche !!!!


    avec un petit bémol !

    >> ça marche très bien ici >> (http://php.educanet2.ch/ceij/wiki) où la version Mst a été installée à neuf
    >> ça marche très bien ici >> (http://php.educanet2.ch/veronique/wiki) où la version Mst a été installée après avoir écrasée la version standard 0.4.3
    >> ça ne marche pas complètement ici >> (dans ce wikini)
    1. L'éditeur d'édition ne fonctionne pas du tout
    2. Les scripts java que nous avions précédemment (statistiques) ne sont pas reconnus et provoque un bug qui ne permet plus de visualiser à l'écran tout ce qui se trouve au-dessous du script
    3. Notre Calendrier montre un bug que je ne comprends malheureusement pas !

    • PL: Allez inscrire l'adresse de votre wikini dans wakka.config.php à la ligne: "url_site" => "http://recitmst.qc.ca/wikinimst" MERCI, C'ETAIT VRAIMENT UNE BETE ERREUR PAR OMISSION DE MA PART !! Je n'avais pas corrigé l' "url-site". Merci beaucoup !

    (27 janvier 2005)
    Les contrôles effectués (dans la limite de mes compétences évidemment) :
    • J'ai comparé ligne par ligne les wakka.css et wakka.basic.css de la version actuelle et de celle d'origine du Mst
    • J'ai recontrôlé le fichier wakka.config pour voir si tout avait bien été installé correctement
    • J'ai compris qu'il doit s'agir du répertoire ACEDimages, qui contient justement les images de la barre d'édition
      • Ce répertoire ne contient que les images. Les page qui contrôlent la barre d'édition sont Aceditors.php et Aceditors.buttonsbar.php.
        (28 janvier 2005)
        >> J'ai fait le tour de tous les fichiers sur ftp (sur les trois sites wikini sur lesquels j'ai installé la versions Mst, et même dans le répertoire original du wikiniMst complet), et n'ai trouvé nulle part Aceditors.php. Il y a bien un fichier AcEditor?.buttonsBar.php, un autre intitulé AcEditors?.js et le répertoire contenant les images ACEdImages.
      • Ho! Avez-vous la dernière version du WikiniMST? SourcesDuWikiniMST Vérifiez dans cette archive, les fichiers sont là. Ils doivent être présents, sinon, ça ne fonctionnera pas.

    Qu'en pensez-vous ?


    PL: J'aurais besoin des message d'erreurs que vous obtenez et de l'adresse où vous avez trouvé le script de statistiques.
    (28.01.05)
    • Voici donc le script que nous utilisions :
    • le message d'erreur :
      1. jusqu'à hier plus de possibilité d'affichage de tout ce qui se trouvait en-dessous du script
      2. depuis aujourd'hui (après le changement dans wakka.config), plus d'erreur, mais rien ne se passe, c'est-à-dire qu'il n'y a aucun affichage particulier (comme si rien n'avait été ajouté)
      3. j'espère que je ne vous importune pas trop avec mes questions un peu techniques ?
      • Non non, j'apprends :o)
      • Est-ce que ce script fonctionne sur un wikini 0.4.3 de base? Je crois que depuis cette version, le javascript ne passe plus dans les page pour une raison de sécurité.

    <script language="JavaScript?" src="http://www.geo-loc.com/enter.php?id=4132" ></script><noscript><a href='http://www.geo-loc.com'>GEOLOC>
    <script language="JavaScript?" src="http://www.geo-loc.com/in.php?id=4132" ></script><noscript><a href='http://www.geo-loc.com'>GEOLOC>

    <h1><font color=blue>Coucou</font></h1>
    <!-- Begin Nedstat Basic code -->
    <!-- Title: Le bureau de Corinne et Véro -->
    <!-- URL: http://php.educanet2.ch/corinne -->
    <script language="JavaScript" type="text/javascript" src="http://m1.nedstatbasic.net/basic.js">
    </script>
    <script language="JavaScript" type="text/javascript" >
    <!--
      nedstatbasic("ADIvyQmyERfRQVOe/nwLGjrxMVZg", 0);
    // -->
    </script>
    <noscript>
        <p><a target="_blank" href="http://www.nedstatbasic.net/stats?ADIvyQmyERfRQVOe/nwLGjrxMVZg"><img
    src="http://m1.nedstatbasic.net/n?id=ADIvyQmyERfRQVOe/nwLGjrxMVZg"
    border="0" width="18" height="18"
    alt="Nedstat Basic - Statistiques gratuit des sites web
    Page d'accueil website compteur"></a><br>
    <a target="_blank" href="http://www.nedstatbasic.net/">Compteur gratuit</a>
    </noscript>
    <!-- End Nedstat Basic code -->

     
    IMP :: RSS :: HTML :: TXT :: Clone :: Historique :: Propriétaire : CoRinne